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Thank you for using INSIGHT  Express. We hope you find it useful and easy
to use. This documentation explains all basic operations which INSIGHT
allow you to perform to manage, search and retrieve your documents.

Performing a Search

Defining the query is the first and most important step in retrieval operations.
This process involves four steps:

• Defining the query.

• Entering the query text including any logical operators.

• Viewing the results.

Defining a Query
Any word you type in the full-text field will retrieve all documents containing
it. If you type in "Multimedia" in the Full Text field, the search will
encompass any occurrences of "Multimedia”.

Viewing the Results
When you click OK, the Query Response window shown in Figure 22.4
appears.

Quitting the Query Results

Clicking on the   button quits the query results and the main screen
reappears. At this point you can either perform another query as explained
below or exit from your title as explained in the next section.

Performing Another Query

If you want to change the query terms and perform another query, click on
Search, and the query dialog reappears.

After you enter the query text and click OK, the Search Results reappear, and
if desired you can decide on a different view of the query results.

Exiting from your Title

Clicking on  the Exit option on the File menu or pressing ALT X exits you from
INSIGHT  Express.
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Viewing the Search Results

To provide you with the maximum flexibility in viewing the query results,
INSIGHT Express offers a variety of ways to present the display which meets
the query conditions:

• Full pages of text.

• The text surrounding hit words.

Suppose you want to quickly look at more instances of the query results. To do
so, proceed as follows:

1. Click on the Viewing Mode scroll bar on the Search results window.
This displays the viewing mode options (see Figure 23.1b).

2. Click on Abbreviated Results.

Abbreviated Results
The Abbreviated Results option is used to display larger portions of the
information taken from several documents that matched the query. The
resulting display consists of the text surrounding each occurrence of the
hit-word on the page.

There are two ways to view the full document:

1. Double-click on the blue document title OR

2. Click on the blue document title (a red checkmark appears) and then
click on the View button.

Viewing Documents

This part describes the tools available when working with a full view of the
documents retrieved, including:

• The screen format

• Navigating through documents

• Viewing multiple documents

• Zooming
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• Copying text or images to other applications

• Printing

• Using windows operations

Screen Format

Heading
This section at the top of the screen contains the name of the title and the
name of the document currently being viewed..

Menu Bar

This section under the heading contains eight separate menu entries:
File; Edit; Query; Zoom; Navigation; Annotation; Window and Help.

Toolbar

If specified by the publisher, this section under the menu bar contains buttons
for simplifying menu operations when using most of the features on your main
menu. Options which are grayed on the pull down menus are not available and
will not have a shortcut button.

The composition and position of the toolbar buttons may vary for each title.

Navigation Buttons

This section at the bottom left of the screen contains buttons for simplifying
navigation through documents.

All the navigation buttons described briefly below can be activated from the
Navigation menu shown on the right.

Next Page
with Hit

Moves to the next page in the document where the
next hit word is located.

Prev Page
with Hit

Moves back to the previous page in the document
where the previous hit word is located.

Next Doc
with Hit

Moves to the next document where the next hit word is
located.

Prev Doc
with Hit

Moves to the previous document where the previous
hit word is located.

Next Page Moves to the next page in the document.
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Prev Page Moves to the previous page in the document.

Another Moves to the next document where the next hit word is
located and opens it in a separate window.
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Navigation Process
Once you have defined a query, specified the "view page" view mode and are
actually looking at the first document retrieved -  you can use the navigation
buttons to:

• Move back and forth to and from documents containing hit words.

• Page back and forth through the documents in sequential order without
regard to the hit words (i.e., even if they did not match the query).

Navigation Inside Documents
Once inside a document, you can easily and quickly navigate from one side to
the other using the horizontal scroll bar, or up and down using the vertical
scroll bar (see Figure 25.1).

1. To move a scroll bar, click on it and keep it pressed while dragging the
mouse.

2. To move quickly to a remote position, click on the bar at that point.

For example, if the vertical scroll bar is near the bottom of the document,
clicking on the bar near the top will move you close to the top of the
document.

3. To move slowly in any direction, click on the appropriate arrows on the
bar or use the appropriate ARROW KEYS on the keyboard.

4. To move to the next or previous screen, use the Page Down or Page Up
keys.
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Jumping Inside Documents
If you want to go directly to a specific page in a document containing more
than one page, click on Go to Page, and the dialog box appears.

Page The page number where you want to jump.

JumpLink The link in the document where you want to jump. For
defined links, clicking on the arrow (after selecting the
JumpLink radio button) opens a list box.

Moves back to the previous page in the document.
(dimmed if you are on the first page)

Moves forward to the next page in the document.
(dimmed if you are on the last page)

Moves back to the first page in the document.
(dimmed if you are on the first page)

Moves forward to the last page in the document.
(dimmed if you are on the last page)

Moves to the page entered in the Page box.

Notes: 1. If there is only one page in the document, this operation is
meaningless, and all the page navigation buttons will be dimmed.

2. Clicking in the x\y region on the navigation bar at the bottom of
the page also opens the GoTo dialog box.
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Viewing Multiple Documents

Once you have used the navigation buttons to move back and forth through the
hit-word documents or any of the other documents in the sub-databases
selected, you can take advantage of  tools for viewing more than one document
at a time.

Closing and Iconizing Windows

If you are finished looking at one of the windows and want to close it, double-
click on the button in the upper left hand corner, and the window is removed
from the screen.

If you are temporarily finished looking at one of the windows but want to keep
it on the screen as an icon, click on the down arrow in the upper right hand
corner, and the window appears as an icon near the bottom of the screen.

If you want to restore a window on the screen, double-click on its icon.
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Zooming and Panning

Zooming and  panning operations are implemented on the Zoom menu.

Whole Page

This option shows how the query result for Document 13 appears in a full
page layout.

Click on the Whole Page option on the Zoom menu or on the  button, and
the entire document is shown in reduced size on the left of the screen.

NOTE: Occasionally some distortions such as overlap and amplified font
sizes may appear in the display.

Clicking on the 100% option on the Zoom menu or on the  button returns
the page to its full size.

Page Width

This option shows how the query result for Document 8 appears in a page
width which fills the screen horizontally.

Click on the Page Width option on the Zoom menu or on the  button, and
the document is resized to fit horizontally in the window.

Clicking on the 100% option on the Zoom menu or on the  button returns
the page to its full width.

Zoom Selected
This option enlarges a selected portion of Document 13 and its immediate
surroundings to a size that fills the screen. First select the portion you want to
enlarge by clicking the right mouse button and dragging. Figure 25.14a shows
an example.

Then click on the Zoom Selected option on the Zoom menu or on the 
button, and the enlarged document appears as shown in Figure 25.14b.

Zoom Percentages

This option enlarges or reduces the page being viewed according to the
percentage option you click on.
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Click on the 200% option on the Zoom menu or on the  button, and the
document is shown enlarged to 200%.

Clicking on the 100% option on the Zoom menu or on the  button returns
the page to its original size.

Copying Text or Images to other Applications

These operations can copy a selected area of text on the screen to the clipboard
for pasting into other Windows applications on your computer. A selected area
can also be deselected.

Copy
This option enables you to select an area of text in the document for copying
to the clipboard.

Clicking on Copy on the Edit menu, pressing Ctrl+C or clicking on the 
button copies the selected area into the clipboard.

There are two different ways to select an area:

Selecting text - If you start to select an area and the cursor progresses

2. Selecting a graphic image
cursor moves smoothly without capturing complete lines, the area
selected will be copied as a graphic image.

If the area is selected as text, it enters the clipboard as ASCII text
and loses its layout and font indicators.

Use this to append the selected text in the document to the text in the
clipboard.

Ap on the Edit menu or clicking on the  button appends

Copy Document
Use this to copy all the text in the document directly to the clipboard.

Copy D  on the Edit menu or clicking on the 
copies all the text in the document into the clipboard.

Clear

query result.
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Clicking on Clear on the Edit menu, clicking on the  button or clicking on
the background itself deselects the selected background.

Select All
Use this you to select the entire area of text on the page.

Do this by clicking on the  button, clicking on Select All on the Edit menu
or pressing Ctrl+A. Use the Copy option to copy the selected area into the
clipboard.

Finding Text in the Query Results

This option enables you to find text directly in the document currently
displayed in the query results.

It includes standard Find operations for searching up, down or from the top
and matching by case or whole words.

In addition, the Find What box saves the find terms that you have already used
in a term wheel for subsequent scrolling.

The term entered in the Find What box is highlighted when it is found.

Printing

INSIGHT has a WYSIWYG (what you see is what you get) print option for
printing a hard copy of a document.

Clicking on  the Print option on the File menu or clicking on the  button
displays the printout selection window shown in Figure 25.17.

In addition to the standard Windows print options, this window enables you to
specify how much of the document to print.

There are three print range options (Full Page only):

Entire document Prints out the entire document currently displayed in
the query results (default option).

rrent page
displayed in the query results.

P From:   o: Prints out the specified range of pages in the

NOTE: not shaded.
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Windows Operations

These include standard Windows operations which you can use for
conveniently arranging the windows you have opened. Window operations are
implemented on the Window menu.

Tile Horizontally

This option provides a horizontal equivalent area for each of the windows.

To use it, click on Tile Horizontally or click on the  button.

Tile Vertically

This option provides a vertical equivalent area for each of the windows.

To use it, click on Tile Vertically or click on the  button.

Cascade

This option shows all the open windows on the screen as a cascade.

Cascade or click on the  button.
See Figure 25.5 for an example.

Arrange Icons

This option arranges the icons from windows you have minimized.

To use it click on Arrange Icons or clicking on the  button.
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Close All

This option closes all the open windows.

To use it click on Close All or click on the  button.

This option closes all the windows but the curently active one.

To use it click on Windows  button.

View Headers

CREATOR module.

View H  or click on the  button.

View Tooltips

This toggle display the tooltips over the buttons on the toolbar.

To use it click on View Tooltips or clicking on the  button.
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Advanced Searching

This part describes a number of advanced querying methods for both
enhancing and enriching the querying process, including:

• Logical operators

• Proximity querying

• Combined queries

• Multiple wildcard combinations

Multiple Wildcard Combinations

Two commonly used wildcard symbols "?" and "*" can be used in a variety of
combinations for formulating queries. These symbols can be inserted into a
word as a prefix, a suffix or somewhere in the middle of the word.

• The "?" symbol represents any character at a given position in a
word. It is limited to a single character.

• The "*" symbol represents the characters preceding or following it in
a word. It can be any number of characters.

The wildcard combinations available in INSIGHT are summarized:

Wildcard Wildcard Examples

con* pla?e plate, plane, place

*con? *com intercom

?con* ?con? icons (but not icon)

???ed *con* icon, icons, preconditions

c???? p?a?e (option not available)

Logical Operators

Logical operators are predefined symbols or words which enable you to enrich
the querying process by adding conditional (Boolean) statements to the
querying terms. The operator is defined by the publisher and can be entered
using upper, lower or mixed case characters (upper case is used here for
clarity).

For example, a query based on the term "image" can be linked to the term
"graph*" by using the "AND" logical operator (the asterisk after graph is a
wildcard) and can be expanded to also include the term "video" by using the
"OR" logical operator.
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1. If you want to query on "and, or, not" instead of using them as a

Invalid: 

Valid:  to be

2.
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Boolean expressions contained in parentheses will be analyzed first.

Proximity Querying

based on how close words are to other words in these documents (sometimes
referred to as Metrics or Word Adjacency). The order of the search is the same

usually results in a more effective search, but may prolong search time.

An  database can have up to two levels of proximity:

•

• within Y sentences

This proximity option performs searches based on how close a retrieval word
is to other retrieval words of the same kind in terms of words. The

publisher of the title).

The default search proximity for a query on words adjacent to each other is
. This means that the term "United States" would automatically translate to

the query "United"  of  "States", the equivalent of "United !1
States". Changing it to "United !3 States" translates to  "United" 
words of  "States".

To search for hyphenated words, you must enter the two words without
hyphen between them.

Sentence Proximity

is to other retrieval words of the same kind in terms of sentences.

Entering a zero next to the sentence proximity operator directs the search to
same sentence as another word.
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Querying Tools

This part describes a number of querying tools for both enhancing the
querying process and making it more convenient to use, including:

• Nested Search

• Saving and loading queries

Nested Search
This option enables you to enter a new query while reviewing the initial query
and without effecting the initial query.

To do so, click on the Nested Search option on the Query menu or click on the
 button. This displays the Nested Search dialog box.

TIPS: 1. The "Within previous results" box on the Nested Search dialog
box enables you to limit the new query search to the query
results obtained in the previous query.

2. You can enter logical operators (AND, OR, NOT); word
adjacency, proximity operators (word, sentence) and wildcards.

3. Instead of typing the query text in the Nested Search dialog box,
you can select text from the document. To do so, highlight a
portion of the text and then activate Nested Search.

After you click OK (without clicking "Within previous results"), the new
query is issued.

Saving and Loading Queries
INSIGHT Express provides a convenient tool for saving frequently used
queries so that you don't have to type them in again. This involves two
separate operations:

• Saving a new or updated query.
• Loading a previously saved query.

Saving a Query   
To save the current expression, click on Save Expression or the  button to
display the Save Expression dialog box.
You can use this box to save a new query and load it in later using the Load

Expression option.
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Note that the optional extension .qry is given to the saved query files so that
they can be recognized later on as query files.

Loading a Previously Saved Query   

You can use this box to load a query that you have previously saved.

To load an existing expression, click on Load Expression or the  button to
display the Load Expression dialog box.

NOTE: You can only load queries that you have saved previously for the
same sub-database.
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Marking Tools

This part contains a detailed description of the steps involved in adding
annotations and bookmarks to the database as well as managing them,
including:

• Adding an annotation

• Annotation manager for editing, deleting or finding annotations

• Adding a bookmark

• Bookmark manager for editing, deleting or finding bookmarks

Adding an Annotation

Annotations can be added to every document. This facility enables the user of
the database to add textual enhancements to it.

Selecting a Region

First select the region on a document where you want to position the
annotation.

To do so, click (a cross symbol appears) and drag with the left mouse button to
cover the region desired, and then release the button.

The selected region is surrounded by a dotted box to make it easily visible.
You can also drag horizontally over text, and the selected area will be shaded
in black.

To cancel the selection, click on the region again.

When you are satisfied with the selected region, click on the  button or on
the Add Annotation option on the Annotation menu.

This opens the dialog box:

Clear Clears the contents of the Annotation dialog box.

Delete Deletes the Annotation in the dialog box.

The Annotation Icon
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Click in the dialog box to bring up the text entry cursor, and type in the
contents of your annotation. After you click OK, a yellow annotation icon
appears on the annotation region.

NOTE:
You can have as many annotations per page as you
would like, but make sure that the annotation
triggering areas do not overlap.

Viewing an Annotation

To view an annotation, double-click on the yellow annotation icon. The cursor
changes to a paperclip, and then the Annotation dialog box appears.

Note that yellow annotation icons are only displayed for the ones the user is
authorized to view. These include all public annotations and the user’s private
ones.

Managing Annotations
Annotations can be viewed, edited, deleted or searched for using the
Annotation Manager.

To enter the Annotation Manager, click on the  button or on the
Annotation Manager option on the Annotation menu. This opens the following
window:

Text First fifteen characters of the annotation text.

Date The date the annotation was created.

Document
Title

First eighteen characters of the document title which appears
under the toolbar in the document display.

Viewing Annotations

Opens the Query Results window where the annotation is
located for each highlighted line. To pop up the
Annotation window, double-click on the clip icon.

Editing Annotations

Opens the Annotation dialog box for the highlighted line.
You can now modify the annotation text.
Click on the Clear button to remove all the text in the box.

Deleting Annotations
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Deletes the annotations for the highlighted lines.

A confirmation message appears. Click on Yes to Delete
or No to return.

NOTE: 

After the session is finished, all annotations added will remain in the
Annotation Manager unless you delete them here.

It is good practice to periodically review the list and delete any unnecessary
ones.

Searching for Annotations

Highlights the lines containing an annotation which
matches the text entered in the Annotation Search dialog
box.

Changing your Mind

Closes the Annotation Manager window and does not
make any of the changes entered.

Displaying Several Annotations

You can display more than one annotation at a time by highlighting them and
then clicking the Go To button.

A separate window is opened for each line highlighted.

To bring up the next highlighted annotation on the Annotation Manager
window, click on the Next Annotation option on the Annotation menu.

TIP: Before defining a new query, you can use the Annotation Manager to
view any previously defined annotations, but you cannot add one.
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Adding a Bookmark

Bookmarks can be added to every document. This facility enables the user of
the database to mark particular locations for quick future access.

Selecting a Region

To select the region, click (a cross symbol appears) and drag with the left
mouse button to cover where you want to position the bookmark, and then
release the button.

The selected region is surrounded by a dotted box to make it easily visible.
You can also drag horizontally over text, and the selected area will be shaded
in black.

To cancel the selection, click on the region again.

When you are satisfied with the selected region, click on the Add Bookmark

option on the Annotation menu. This opens the Add Bookmark dialog box.
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Managing Bookmarks
Bookmarks can be viewed, edited, deleted or searched for using the Bookmark
Manager. To enter the Bookmark Manager, click on the Bookmark Manager

option on the Annotation menu.

NOTE: The procedure for viewing, editing, deleting and searching for
bookmarks is the same as the one described above for annotations.

Viewing a Bookmark

There is no icon for a bookmark. To access your bookmarks, use the Go To or
Search buttons in the Bookmark Manager.

The Bookmark Manager list includes all bookmarks.

Displaying Several Bookmarks

A separate window is opened for each line highlighted.

To bring up the next highlighted bookmark on the Bookmark Manager
window, click on the Next Bookmark option on the Annotation menu.


