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· Welcome to Morph Editor

Morph Editor is a fun, easy-to-use program that
allows you to take an image and then transform
that image, or part of it, into another. By
animating this transformation process, you can
create a video sequence which shows the original
image growing out of, or into, the other – such as
a man from a woman or a bird into a plane.

To add an even greater impact to your morphing
work, Morph Editor comes equipped with a
range of advanced special effects and filters that
can enhance and improve your images, turning
otherwise standard morphs into stunning and
eye-catching presentations.

04/21/95 Taurus CONFIDENTIAL
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How to get the most from Morph Editor

Reading this guide is not the only way you can learn about

Morph Editor: the ReadMe file contains technical information

and anything that came to light after this manual was produced,

and the on-line help provides a complete and in-depth reference

which can be easily accessed by pressing the F1 key or clicking

on the help button provided in most dialog boxes.

The following provides a brief overview of the contents for each

chapter in this guide:

1. Getting started, introduces the Morph Editor program window
and provides a reference to the menu commands and tools.

2. Morph Editor basics, describes the basic commands and
features of Morph Editor such as opening and closing morph
files, recovering from mistakes, resizing images and how to
customize Morph Editor. If you are already familiar with
morphing concepts and using Windows, you may wish to skip
this chapter.

3. Morphing, focuses on how to generate a morph video sequence
and provides background information on placing control points
and lines, common morphing techniques and a look at the range
of special effects and filters.

• Index
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1 Getting started

This chapter is designed to get you up and
running with Morph Editor as quickly as
possible. After the introductory section there is a
brief explanation of the menus, as well as tables
referencing where in this guide you will find
descriptions about menu commands and tools.

04/21/95 Taurus CONFIDENTIAL
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1·1
Running Morph Editor

To run Morph Editor, you first need to locate the Morph Editor

program icon. If you followed the suggestions made by the

installation program, the Morph Editor icon will appear in the

Morph Editor program group.

1.1.1 The Morph Editor window

When you run Morph Editor you may see:

• A control window containing both start and end images.

• A composite window containing a preview composite image of
the start and end images.

• A video window displaying an existing video sequence.

• The status bar, at the bottom, displaying information about the
active image and the current cursor position. (Double-clicking
on the status bar opens the Morph Editor preferences dialog box.
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The Morph Editor program window
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1·2
The Morph Editor menus

One of the most common methods of performing operations is

to choose a command from a drop-down menu in the menu bar.

Some of the more important commands also have a

corresponding button in either the control or composite window

toolbars.

When you view menus, some commands appear in black while

others are grayed-out. (The actual colors depend on your current

Windows color scheme.) Commands in black are active and

available for selection, while grayed-out commands are inactive

and unavailable for selection.

Note: A command may be inactive because it is not currently applicable,
(e.g. when there is no morph document open the Close command
is inactive), or when your PC does not have the necessary
hardware to support that particular function.

In each menu, keyboard shortcuts appear to the right of some of

the menu commands. These allow you to perform the

corresponding command from the keyboard – without the need

to access the menu with your mouse.

After many commands you will see a right-pointing arrow or

three dots. The arrow signifies that a submenu exists for that

command while the dots indicate the command accesses a

dialog box. If a command has neither of these, then its effect is

immediate.
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2 Morph Editor basics

This chapter covers some of the more common
functions you will use when working with
images and the Morph Editor program, such as
the Open, New, and Undo commands; there are
also sections on resizing images and how to
customize Morph Editor. It does not detail the
morphing process, which is left for the following
chapter, but does provide useful information if
you are new to morphing and working in a
Windows environment.

04/21/95 Taurus CONFIDENTIAL
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2·1
Standard menu commands

All Windows programs provide some basic commands that have

a lot in common – and if you are familiar with Windows, you will

already know how to use commands such as Open and Save.

This section describes Morph Editor’s Open, New, Save As, Close

and Exit commands and highlights, where necessary, any ways

they differ from other programs.

2.1.1 Opening morph files

After installation you will find a sample morph file (MOF) in the

SAMPLES subdirectory under your installation directory. To

open this file, or any other morph file, choose the Open

command in the File menu. The Open dialog box appears. To

open the sample file, simply click on its filename and press OK.

(Double-clicking on the filename also opens the file.) The dialog

box closes and the file is opened in the Morph Editor workspace.

You can also open files you have recently been working on by

choosing their names from the list at the bottom of the File

menu. The number of filenames that appear is controlled by the

Morph Editor preferences dialog box.

Notes:

• If you open a morph file whose start and/or end images have
been altered in another editing program, the original control
settings may no longer be compatible.

• You can have several instances of Morph Editor open at the same
time; however, only one morph file can be displayed in each
program window.
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Morph files are displayed in the control window, which consists

of two image windows and a toolbar. The image windows

display your start and end images with any control points or

lines that you have defined. The toolbar contains tools for

applying and manipulating the control settings and provides

direct access to commonly used menu commands.

Note: When you position your mouse over a tool in the toolbar, a hint
message appears in the status bar describing the function of that
tool.

A control window
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2.1.2 Creating a new morph document

To create a new morph document, choose the New command in

the File menu. This opens the New dialog box which allows you

to select your start and end images. To choose the start image,

(the one to be morphed from), check the Start Image option at

the top of the dialog box and select the image you want from the

filename list box. To choose the end image, (the image to be

morphed to), check the End Image option and select another

file. You can conveniently toggle between the two options by

holding down the Shift key (for the start image) or the Ctrl key

(for the end image) as you click on a filename.

The New dialog box also allows you to choose whether or not to

use the original files of your selected images or create a copy of

them by checking the Open Copy checkbox. (When the morph

document is created, the images will appear as “untitled” in

their respective image windows.) It is a good idea to use copies if

you are using the original images for other work and don’t wish

the files to be affected by any editing you may do in Morph

Editor.

Notes:

• Both images placed into a control window must be of the same
dimensions. If they are different, you have the option to crop or
resample them accordingl.

• The total number of pixels in an image must be divisible by 4. If it
is not, Morph Editor automatically crops the image. (At most this
will result in a loss of 3 pixels.)

• Morph Editor only works with Grayscale or RGB True Color
images. If you use an Indexed or Hi-Color image, it will be
converted to RGB True Color; Black & White images are converted
to Grayscale.
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Placing images into a control window

You do not have to select both a start and end image when you

create a new morph document. If you wish, you can select one

image and add another at a later date using the Load Image

dialog box, opened by clicking on the load image button in the

toolbar, or by clicking inside an empty window. If, at a later date

you want to replace one or both of the images in a morph

document, choose the Load Start/End Image command in the

File menu; this opens the same Load Image dialog box.

If you have an installed TWAIN device, such as a frame grabber

or scanner, you can input images directly into the control

window using the Acquire command in the File menu. Choosing

this command opens the Acquire dialog box. In this dialog box

you can specify the filename, drive and directory of the file to be

created. Once created, the image is saved to disk and

automatically placed in the currently active start or end image

window, replacing any existing image.

Notes:

• Before you use the Acquire command, you have to select a
TWAIN device in the Select Source dialog box, opened by
choosing the Select Source command in the File menu.

• If you want to copy the active image from one image window to
other, choose the Duplicate command in the Morph menu.
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Swapping the start and end images

Whenever you perform a morph operation, the start image

changes into the end image. There may be times, however, when

you want the end image to change into the start image. This can

be done easily by choosing the Swap command in the Morph

menu. This switches the positions of the images so that the start

image becomes the end image, and the end image becomes the

start. (This command is disabled if you only have one image

open.) Any control points and lines are also switched, thereby

allowing you to immediately perform a morph operation

without needing to redefine the control settings.

2.1.3 Saving a morph file

When you want to save a morph file, Morph Editor provides two

commands: Save and Save As. Use Save when you wish to

update changes to the file you are currently working on and Save

As when saving new files, or to save a file to a new directory

and/or filename.



MORPH EDITOR BASICS 17

The Save As dialog box also allows you to include preview

information with the morph file by checking the Include Preview

Info checkbox. This uses both images in the control window as

the preview sample. (Preview samples are only displayed if the

program accessing them can read preview information, e.g.

many Open dialog boxes have a preview sample allowing you to

see the content of the selected file.)

Notes:

• If you are saving a morph file for the first time, standard save
dialog boxes appear for each of the images in the control
window. Use these dialog boxes to overwrite the existing file or
to save them to a new filename and/or destination.

• To save the active image to a new or existing file, choose the
Save Active Image As command in the File menu.

2.1.4 Printing files

To print your work, you can send the active image to any

Windows-compatible output device. Before you print, however,

make sure that your output device is turned on, connected, and

selected in the Printer Setup dialog box. You can access this

dialog box through the Printer Setup command in the File menu.

Note: The Printer Setup command allows you to change the current
printer options including the orientation of the page from
landscape to portrait, and the paper size.
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When you are ready to print, choose the Print command in the

File menu. The Print dialog box opens. In this dialog box you

have a number of options to control the printed output.

The Scale to Fit the Page option scales images to be as large as

possible on the page while maintaining their aspect ratio. With

this option unchecked, images print at the size determined by

their resolution. The Center Image Horizontally, Center Image

Vertically and Start From Top Left Corner options allow you to

choose where images print on the page. If both the center

options are selected, images print centered on the page.

(Choosing these options disables the corresponding From Top or

From Left option.)

2.1.5 Closing files

When you have finished working on a morph document, or wish

to remove it from the workspace, you can close it. This can be

done in one of the following ways:

• choosing the Close command in the File menu.

• double-clicking on the control window’s Control menu box

• choosing the Close command in the control window’s Control
menu.

When you close a control window, both itself and the composite

window (if open) disappear from the workspace. If you have not

saved the morph document, or have made changes since you

last saved it, a message box appears asking if you want to save

the changes. Selecting No discards any changes; Yes saves them.
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2.1.6 Exiting Morph Editor

If you have finished working with Morph Editor, you can exit by

closing the program window from the Control menu, or by

selecting the Exit command in the File menu. When exiting

Morph Editor, you will be asked if you want to save any new

morph documents or any changes made to a previously saved

morph file. Selecting No discards any changes; Yes saves them.
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2·2
Recovering from mistakes

Morph Editor provides two commands for recovering from

mistakes you make: Undo and Restore. The Undo command in

the Edit menu reverses the last applied command (where

possible) and returns the morph document to its state prior to

the application of the command. (Undo will only undo the most

recent change.) Instead of Undo at the top of the Edit menu, you

may see Redo. This appears after the you have “undone”

something, effectively allowing you to undo the undo.

The Restore command in the File menu allows you to undo all

the changes made to the current morph document since it was

last saved. For example, if you have been experimenting with a

variety of effect commands, you can restore the morph file; the

images and settings are restored to their last saved version. (This

essentially closes the file and reopens it.) Before using this

command consider carefully, as this cannot be undone.
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2·3
Resizing images

Morph Editor provides two commands for controlling the size of

your images: Crop and Resample. Resizing your images is

important, not only for making your images more manageable,

but also because both the start and end images in a control

window must be of the same dimensions.

2.3.1 Resampling an image

Resampling works by enlarging or reducing the size of an image

by increasing or decreasing the number of pixels that the image

contains. This allows you to stretch or squash images to fit a

specific size.

To resample an image:

1. Click on the image in the control window you want to resample
to make it active.

2. Choose “Resample” from the Edit menu. The Resample dialog
box appears containing information about the width and height
of the image.

3. Check the Keep Aspect Ratio option to retain the proportions of
the image. Uncheck this option to independently change the
width and height of the image.

4. Enter the new width and height for the image. (When Keep
Aspect Ratio is checked, entering one value automatically
adjusts the other value.)
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5. Click on the Resample or Manual Crop options in the Start/End
Image group box to resize the corresponding image accordingly.
(These are disabled if there is only one image in the control
window.)

6. Click OK. The active image is resampled. The second image (if
there is one) is resampled accordingly or opens in the Crop
dialog box.

Notes:

• Resampling up generates new data, thereby increasing the size of
the image file. Conversely, resampling down discards data and
results in a smaller file, but may reduce image quality.

• If a control window has an existing start or end image, and you
insert a smaller image, the image is automatically resampled up.

2.3.2 Cropping an image

Cropping is a way to trim the edges of an image and is therefore

helpful in allowing you to control the size and position of the

subject of your image. When you crop an image, the cropped

portions cannot be retrieved again, unless you immediately

undo the Crop command or restore the morph file.

To crop an image:

1. Click on the image in the control window you want to crop to
make it active.

2. Choose “Crop” from the Edit menu. The Crop dialog box opens
displaying a sample of the active image with a cropping border
positioned in the center.

3. Drag and resize the border to include the areas of the image you
want retained.
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4. Select either the Auto Crop, Manual Crop or Resample options
at the bottom of the dialog box to resize the corresponding
image accordingly. (These are disabled if there is only one image
in the control window.) Auto Crop crops the second image
according to the location of the cropping border in the sample
image. Only use this option if the subject to be morphed in both
images is in the same position. If you need to selectively crop the
second image, choose Manual Crop. This crops the first image
and then reopens the Crop dialog box, allowing you to reposition
the cropping border over the subject in the second image. The
Resample option resamples the second image to the dimensions
of the cropped image.

5. Click OK. The dialog box closes and the active image is cropped.
Depending on your selections, the other image (if there is one) is
also cropped, resampled or opens in the Crop dialog box.

Note: If a control window has an existing start or end image, and you
insert a larger image, the Crop dialog box opens, allowing you to
crop or resample the image.

The start image has
been cropped and

the end image
resampled
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2·4
Using the clipboard

The clipboard is a temporary storage area for any type of

information. This can be an image, text, sound or even a control

point; but the clipboard can only hold one piece of information

at a time. When you place something onto the clipboard,

existing clipboard data is overwritten; irrespective of whether

you placed new data on the clipboard from Morph Editor or

another program.

Morph Editor allows you to place two kinds of data onto the

clipboard: images and settings. To place the active image onto

the clipboard, choose the Copy Image command in the Edit

menu. You can then paste this image back into a control window

(e.g. as the end image) or into the Image Editor program for

further editing and enhancement.

Choosing the Copy Settings command from the same menu

places the current control settings onto the clipboard (this

includes all control points and/or lines). This is useful when you

want to save the current control points and lines and place them

into a new control window or a control window in another

Morph Editor program window.

Note: To view the contents of the clipboard, choose the Clipboard
Viewer command in the Switch menu. This opens Windows
Clipboard Viewer, (control settings data cannot be displayed).
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Pasting data from the clipboard

After copying data onto the clipboard, you can paste it into the

active image window of a morph document by choosing the

Paste command in the Edit menu. When pasting image data,

your new image replaces the active image and will be resampled,

where necessary, to the size of any existing start or end image.

When you paste control settings, they must be pasted into a

morph document whose images are the same dimensions as

those they were copied from, (the control window must also

contain both a start and end image).

Note: Morph Editor only allows you to work with Grayscale and RGB
True Color images. If you paste in an Indexed or Hi-Color image,
your new image will be converted to True Color; Black & White
images are converted to Grayscale.
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2·5
Viewing

When you display images in Morph Editor, the image pixels are

“mapped” onto your screen pixels. Controlling the mapping of

these pixels determines the way you see the images. This section

takes a look at the ways you can control the view of images as

well as how to display file and system information.

2.5.1 Changing the magnification of an image

When you are placing and moving control points, you may want

to see the image in greater detail or more of the image at a

smaller size. You can do this in two ways: with the Zoom In and

Zoom Out commands in the View menu or by using the zoom

tool. If you choose the Zoom In command, you can zoom in up

to 8× the actual view. To reduce the view, choose the Zoom Out

command. This allows you to zoom out up to ⅛× the size of the

actual view. (To return to the actual view of an image, choose the

Actual View command in the View menu or, if using the zoom

tool, click the right mouse button.)

Locking the images in view and position

Often when you are changing the view of an image, you want the

corresponding image to change as well. In Morph Editor you can

do this by clicking on the lock button in the toolbar. This joins

the two images together, and any changes made to the zoom

level or position of one is reflected in the other. (Click again on

the lock button to unlock the images.)
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Using the zoom tool

The zoom tool provides an alternative to the Zoom In and Zoom

Out commands and allows you to accurately zoom in on

particular areas of an image. You can use the zoom tool in a

number of ways:

• clicking the left mouse button zooms in on the area under your
mouse pointer.

• holding down the Shift key and clicking the left mouse button
zooms out from the image.

• clicking the right mouse button returns the image to actual view.

Notes:

• You can also press the “+” and “-” keys to zoom in and out on
images respectively.

• To switch to the zoom tool temporarily, hold down the Z key.
Releasing the key returns the pointer to the currently selected
tool.

Zooming in on both
images at 4× actual

view
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Repositioning an image within its window

When you zoom in on an image, parts of the image may be

hidden by the frame of the window. To reposition the image so

that the hidden areas are displayed, use the scroll bars or the

move tool. The move tool is a more convenient method and

allows you to “slide” the image around the window by simply

dragging it with your mouse. This reveals those portions of the

image previously hidden.

Note: You can switch to the move tool temporarily by holding down
the M key. Releasing the key returns the pointer to the currently
selected tool. This allows you to maintain your focus on the work
at hand, without having to move your mouse to change tools.

Fitting an image within its window

If you want to increase the magnification of an image, but keep

the image displayed within the window frame, use one of the

available zoom commands from the View: Fit in Window

submenu. (The maximum zoom level available is determined by

the size of the image and the resolution of your current display

mode.)
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2.5.2 Managing images

When you first create or open a morph file, the start and end

images appear next to each other. If you are working with images

that are wider than they are high, you can choose to stack them

with the Tile Horizontally command in the View menu. To

return to displaying them side by side, choose the Tile Vertically

command. An alternative to choosing the tile commands is the

tile button. Clicking on this button toggles the two images

between tiling vertically or horizontally.

Placing images on top

Most of the time you will be working with two images and prefer

to see both images tiled side by side. There may be times,

however, when you would prefer only one image to be

displayed, e.g. when performing special effects or applying

control points at a high zoom level. To view only one image,

click on the layout button. This places the currently active image

“on top” of the other. To switch the image appearing on top with

the one behind (if there is one) click on the tile button.
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2.5.3 Displaying information

Morph Editor provides information about the active image and

your system’s status with two commands in the View menu:

Morph Information and System Information. Choosing the

Morph Information command opens the Morph Information

dialog box. Here you can find information about the morph

filename (where applicable), the filenames of the start and end

images, the active image’s width and height (in pixels), the total

number of control points and lines and the quality level of the

morph sequence.

The System Information command opens the System

Information dialog box. Here you can find information about

Windows, including the version number, your current mode,

available system memory and relevant disk information such as

the current directory, size of your disk and available disk space.

There is also a section on your display as well as the capabilities

of your monitor.
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2·6
Customizing the way you work

The Preferences command in the File menu provides a submenu

of five commands that can be used to customize the way you

work. The following section discusses each of these commands

and details how you can use them to improve the way Morph

Editor works for you.

2.6.1 Morph Editor

Choosing the Morph Editor command, pressing the F6 key, or

double-clicking on the status bar opens the Morph Editor dialog

box. In this dialog box you can choose to change the colors of the

control points and lines, the quality of the morph process and

the number of filenames kept.

To change the color of a control setting, simply click on the

appropriate color square. The standard Windows color dialog

box opens displaying available colors you can choose from. You

should change colors whenever you find it difficult to distinguish

the control points against the background of the images you are

working on. When you save a morph file, the control setting

colors are remembered.

Note: New control windows take their control point and line colors
from the last opened file.
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The Quality group box is used to control the relationship

between morphing speed and the quality of the resulting

composite image or video sequence. Which option you select

depends on your reasons for performing the morph operation

and the degree of clarity you want. If you are preparing a final

version of your work and want to produce the best possible

results, then select the Best option. If you only want to check

how your work is developing, then select the Fair option.

The Number of Files Kept option allows you to specify how many

files are listed at the bottom of the File menu. This list contains

the filenames of your most recently saved morph files. To open a

file from the list, click on its filename.

2.6.2 Photo CD

The Photo CD dialog box gives you the option of determining

the resolution and data type of any photos imported from a

Kodak Photo CD.
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2.6.3 Display

The Display dialog box allows you to adjust how Morph Editor

displays images. Which options are available depend on your

current display mode. If you are working in a 256-color display

mode, the View Images With a Common Palette option is

enabled. Selecting this option displays images using the default

system palette – this provides reasonable representation of all

images and makes your work quicker because the same palette is

shared by each image. If you want to produce the best colors for

each image, leave this option unchecked, (this does, however,

slow down processing time).

A 256-color display mode also enables the Don’t Care About

Background Quality option. If you have selected the common

palette option, this makes no difference, otherwise select this

option to prevent repainting of background images – giving you

the best representation of the active image in the fastest working

environment. (You cannot, however, compare images with this

option selected.)

The final option present in the Display dialog box is the Monitor

Gamma option which tunes your monitor to the current display.

It is very important that you calibrate your display before you

start working with images for the first time. To learn more about

how to calibrate your display, please refer to the introductory

guide.
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2.6.4 Memory

The Memory command gives you the opportunity to specify

directories which can provide additional working space when

working with images. The first directory shown is the TEMP

directory defined by the SET TEMP statement in your

AUTOEXEC.BAT file. Morph Editor provides a further three

choices that would normally be different drives. If you are

working on a network, you may have different space allocations

on the same drive enabling you to specify more than one

temporary directory from the same drive.

2.6.5 File Formats

The File Formats command allows you to specify which image

and graphics file formats you want Morph Editor to support.

When you the Morph Editor program for the first time, all

available file formats are placed on the active list; this does,

however, occupy system resources. If you only work with a

limited number of file formats, then use this command to

remove unnecessary formats from the active list – in turn

helping free up system resources.

Notes:

• If you have an image currently open in the workspace, the
image’s file format appears with an asterisk indicating that the
format is in use. If you want to remove the format from the
active list first close the image.
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3 Morphing

If you have followed this guide from the
beginning, you will be familiar with the basics of
morphing and be able to navigate around the
Morph Editor program window. This chapter
explains how to perform a morph operation, and
includes sections on placing control points and
lines, common morphing techniques and an
introduction to each of the special effects and
filters available in Morph Editor.

04/21/95 Taurus CONFIDENTIAL
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3.0.1 Before you begin

Morphing is all about change; distorting the features or subject

of one image, the start image, into another, the end image. How

this distortion takes place is controlled by the placement of

control points and control lines. To better illustrate the use and

behavior of these control points and lines, it is useful to take a

look at some of the common effects that can be created in

Morph Editor, beginning with performing a crossfade.

A crossfade occurs whenever you perform a morph operation

without placing any control points or lines. As such, the start

image will gradually fade out while the end image fades in. The

frame halfway through such a sequence consists of 50% of the

start image and 50% of the end image.

Performing a
crossfade of the

start and end
images

The problem with crossfading, however, is the “ghosting” effect,

or shadowing, that occurs when the images are fading in and out

as well as the lack of distortion. By placing control points and

control lines in strategic positions on and around the features of

the images you want to morph, you can better distort how one

image merges into the other.

 Distorting the
image by placing
control points at

each corner of the
square
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Without enough control points, the distortion stills contains

some ghosting, as can be seen in the previous example. The

areas anchored by the control points, however, maintain their

positions and “pull” the start image in towards the end image.

The more control points you place, the better this distortion.

 Distorting the
image by placing
control points on

the circumference of
the circle

In the above example, the start image smoothly distorts into the

end image. Most of the time, however, the subjects you want to

morph will contain features which are not exactly symmetrical,

such as faces, cars and other objects. When this happens you

have to manipulate your control points and lines so that the start

image can shrink or expand into areas of the end image.

 Shrinking and
expanding features

of one image into
another
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3·1
Controlling your morph

Once you have chosen your images to morph, you can begin

placing control points and lines to isolate or pin-point the

subjects in both the start and end images. Placing control points

and lines is as easy as a mouse click – the key to performing

realistic and smooth morph transformations, however, lies in the

correct positioning of these points and lines.

3.1.1 Placing control points and lines

 
To place a control point or line, select the appropriate set point

or set line tool from the toolbar and position your mouse over

the area where you want to begin placing points. When you click

your mouse a control point appears underneath the pointer and

a linked “sister” point appears on the other image. Each time

you click, a new control point is created. If you have the set line

tool selected, and place a second point, a control line is created

joining the two points together. (To connect points

consecutively, hold down the Shift key as you click).

Notes:

• To add a control point to an existing control line, use the add
point tool.

• To connect existing control points to a control line, use the
connect tool.

• Do not place control lines so that they intersect or cross over each
other.

• The maximum number of control points or lines you can place is
320.
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If you do not place enough control points or lines, the resulting

morph video sequence may appear “jumpy”, contain ghost

frames, or the subject may disappear and then reappear towards

the end of the morph sequence. To solve such problems, try

placing more control points and lines on the trouble areas. If

there is no easily identifiable area to target, simply “spray” the

control points evenly over the area and then realign them on the

start or end image accordingly. This will ensure that all aspects

of the start image are pulled, stretched or compressed into the

desired end image.

Note: If you want to protect areas, or confine distortions within areas,
place more control lines along the affected borders, such as the
outline of a head, eye, or edge.

 Placing a control
point and line
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3.1.2 Moving control points

To move a control point once it has been placed, click on it with

the adjustment tool and drag. An alternative to dragging a point

is to first click on the point you want to move, to make it active,

and then place your pointer on the area you want it to move to.

Pressing the “.” (period) key immediately repositions the point

to the location of your mouse pointer.

If you prefer to move control points as you place them, hold

down the Ctrl key whenever you click your mouse on an existing

point, (with the set point or set line tool selected). The pointer

temporarily switches to the sister control point on the

corresponding image. You can then move this point

independently of the other. Releasing the Ctrl key returns the

pointer to the original image.

Notes:

• Whenever you move a control point, any connected control lines
move accordingly.

• You can move control points as you place them by keeping your
mouse button pressed down and dragging. This moves both the
original point and its sister point.

• To switch to the adjustment tool temporarily, hold down the A
key. Releasing the key returns the pointer to the currently
selected tool.
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3.1.3 Deleting control points and lines

The Edit menu contains three commands which allow you to

delete control points and lines: Clear, Clear Lines and Clear All.

The Clear command deletes the currently active point (any

connected control lines are also deleted). Use the Clear Lines

command when you want to delete all control lines (this does

not delete any connected control points). To delete all control

points and lines, choose the Clear All command.

Note:

• Pressing the Shift + Del keys deletes the currently active control
line. (Which line is active is determined by order of placement.) If
you want to delete specific control lines, select the disconnect
tool in the toolbar and click on the line concerned.

• You can also delete control points and lines by simply clicking on
them with the right mouse button, (you must have one of the
control point or line manipulation tools selected first).
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3·2
Previewing your work

As generating morph video sequences is very memory intensive

and time consuming, it is best to have some idea of how your

sequence will turn out before actually committing to the

process. Morph Editor allows you to generate a preview

composite image that can represent any particular frame of the

video sequence. If you wish, you can then save this as an image

file by clicking on the save image button in the toolbar or from

choosing the Save Active Image As command in the File menu.

To preview a composite image, click on the composite image

button in the toolbar. The composite window appears and a

preview image is generated. How much distortion this

composite image shows depends on the ratio defined in the

Factor spin box. To change this ratio, enter in a new value and

click on the composite image button in either the control

window or the composite window’s toolbar. The image is

regenerated. (Selecting a ratio of 90%, for example, generates an

image that has undergone a 90% change from the start image to

the end image.)

Notes:

• An alternative to the composite button is the Compose Image At
command in the Morph menu. If you choose this command a
submenu appears listing the percentages you can select from to
create the composite image.

• To return to the control window, click on the return button in the
composite window’s toolbar. This makes the control window
active.
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3·3
Generating a morph video

Once you have chosen your images to morph, placed and

positioned the control points and lines, you can generate a

morph video sequence. Depending on your images and the type

of system you have, this process may take some time. (To abort,

press the Esc key.)

To generate a morph video sequence:

1. Click on the control window to make it active.

2. Click on the morph video button in the toolbar or choose “Save
Morph Video As” from the Morph menu. The Save Morph Video
As dialog box opens.

3. In the Directories list box, select the drive and directory you
want to save the video file to.

4. In the File Name entry box type the name of your file, (up to
eight characters). You do not need to include an extension as all
video files are saved in the standard AVI file format.

5. Enter a value for the duration of the video sequence and the
number of frames to be included (per second) in the Video
Duration and Frame Rate spin boxes respectively. The higher
the frame rate the smoother the motion of the resulting
sequence. This does, however, increase file size as well as
processing time. (For general purposes try a frame rate of 15.)

Note: To compress the video file, click on the Options button and select
a compression scheme from the Compressor list box. As a
guideline, try Microsoft Video 1 for Grayscale sequences and Intel
Indeo for RGB True Color sequences.

6. To play the video sequence after saving, check the Play Result
checkbox. (If this is left unchecked, you have to open the file
using the Play Video command in the File menu.)
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7. Check the Append checkbox to add the video sequence to the
end of an existing file. This is useful if you want to join several
video files together into one video sequence. Leave this
checkbox unchecked if you want to save the video sequence to
its own file.

Notes:

• You cannot append a video sequence to a Grayscale or 256-Color
video file, or to a file whose frames are of different dimensions.

• Some video display software (and certain display modes) cannot
display appended video files.

8. Select the data type that you want to save the video sequence in
from the Format combo box. This can be either RGB True Color
or Grayscale.

9. Enter a value in the Reverse Sequence checkbox if you want your
morph video sequence to repeat itself in reverse. For example, a
value of 1 saves the sequence as it moves from the start to end
image and then from the end to start image. This is useful if you
are saving a small number of frames and wish to create a “ping-
pong” effect. (Optional)

10. Click OK. The dialog box closes, the composite window appears
and the morphing process begins.

Notes:

• If you edit the images in the control window and wish to
generate the morph sequence again, choose the Save Morph
Video command in the Morph menu. This overwrites the existing
video file and uses the original video settings to save the new
sequence.
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Generating a
“turning page”

effect by mirroring
the control points

on the start image
with those on the

end image

    

3.3.1 Playing back a video sequence

Morph Editor does not directly play back video files, instead it

calls up Microsoft Video for Windows Media Player. This

provides a video window consisting of two controls and a slider

bar. The following provides a brief explanation of each of those

controls and how you can use them to control the playing of

your video files.

Play button – click once to play the video sequence, again to

pause.

File button – provides commands to allow you to change both

the frame dimensions and speed of the video sequence. Other

commands included are Open and Close, Copy, (for copying the

currently displayed frame), Configure and Command.
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3.3.2 Saving the frames in a morph video sequence

An added feature of Morph Editor is that it allows you to save the

frames of a video sequence as individual image files. This is

particularly useful if you are preparing a publication or

presentation and require still images rather than video

sequences. Once saved, you can then choose exactly which

frame (image) in the sequence you want to work with.

To save the frames of a morph video sequence:

1. Click on the title bar of the control window to make it active.

2. Choose “Save Morph Frames As” from the Morph menu, the
Save Morph Frames As dialog box opens.

3. In the Directories list box, select the drive and directory you
want to save the video sequence file to.

4. In the File Name Prefix entry box, type in a name for the file
(maximum 5 characters). Each new file is saved with this prefix,
followed by its creation number, e.g. morph001, morph002, etc.

5. From the List Files of Type combo box, select the image file
format to save your files to.

6. Enter a value for the number of frames to be saved in the
Number of Frames entry box. (The number you put here is the
number of new files that will be created.)

7. Click OK. The dialog box closes, the composite window appears
and the morphing process begins.
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3·4
Applying special effects & filters

Morph Editor comes equipped with a number of advanced

special effects and filters that can add a new dimension to any of

your morph creations. These effects can be used to create a new

image, or animated to produce an effect video sequence.

All the various effect and filter commands in Morph Editor can

be found in the Effect menu and are described fully in the

following section. Whenever you choose one of these

commands, a dialog box opens providing before and after

sample images. These allow you to immediately see the result of

any adjustments you make as well as control the degree of the

effect. You can therefore happily experiment with a variety of

settings without fear of damaging the original image or spending

a lot of time waiting for the effects to be applied.

Notes:

• Choosing the Browse command in the Effect menu allows you to
step forwards or backwards through each of the effect dialog
boxes.

• To redo an effect, choose the Redo command in the Effect menu.
This redoes the last applied effect command.



48 MORPH EDITOR USER GUIDE

3.4.1 Enhancing the colors of an image

Morph Editor provides two commands which allow you to

enhance the color values of an image: Brightness & Contrast and

Hue & Saturation. Use the Brightness & Contrast command

when you want to adjust the lightness and darkness as well as

the difference between areas of light and dark colors in an

image. (For RGB True Color images you can also edit the

individual color channels, red, green or blue.) Use the Hue &

Saturation command if you want to change the color (hue) or

purity (saturation) of colors.

3.4.2 Applying filters

Choosing the Filters command reveals a submenu of specially

prepared filters that can be used to distort or alter an image.

Filters are essentially effects that work by adjusting the pixels in

an image, much like sunglasses reduce the brightness of things

you see. The following pages introduce the filters available in

Morph Editor:
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Add Noise

This filter works by randomly generating pixels of varying

gray/color values. The result is an image that looks as if it has

come from a television encountering static problems. In the

dialog box that appears when you choose the Add Noise

command, the Distribution group box allows you to distribute

this static evenly over the entire image, or in a varied pattern. To

increase the static, drag the Level slider to the right or enter in a

higher value in the adjacent spin box.

Image before and
after adding noise
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Blur

The Blur command allows you to reduce the contrast of pixel

values in an image to create a softer image. By moving the Level

slider to the right in the Blur dialog box, you can increase the

amount of blur, eventually obscuring the entire image.

Emphasize Edges

An edge is defined as the part of an image where significant

changes in color occur. The Emphasize Edges filter outlines such

changes in color, effectively increasing the contrast along edges

by making them harder and more sharply defined.



MORPHING 51

Mosaic

This filter breaks an image into blocks containing pixels of the

same color values. In the Mosaic dialog box you can define these

blocks as square, or change the X and Y axes independently.

Mosaic filters are commonly used to obscure the faces of people

appearing on television, or in print, who wish to remain

anonymous.

Image before and
after applying the

mosaic filter
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Motion Blur

The Motion Blur filter creates the appearance that an image is

moving. This effect is commonly produced in photographs

showing people and objects moving at high speed. In the Motion

Blur dialog box you can change the length of the movement as

well as the angle of direction. A Light Source group box provides

additional options that allow you to specify how light is

produced on the image.

Image before and
after applying the
motion blur filter
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Posterize

Posterize allows you to reduce the number of color levels in an

image. Decreasing the value reduces the number of colors that

can be displayed. For example, if your image has 64 shades of

gray, a level value of 4 will only display 4 of the possible 64. This

filter is useful if you want to create a surreal effect or need to

limit the number of displayable colors due to hardware

constraints. (For RGB True Color images you can also edit the

individual color channels, Red, Green or Blue.)

Sharpen

The Sharpen command increases the contrast between light and

dark pixels in an image. Use this command when your images

appear unclear or the edges are not well defined.

Image before and
after sharpening
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3.4.3 Applying special effects

Special effects differ from filters in that they actually change the

content of images. Whenever you apply a special effect, it is

performed on the currently active image.

Emboss

The Emboss effect displays the outline of an image against a

solid color background. In the Emboss dialog box you can

choose this color from the sample image or from the standard

Windows Color dialog box. To select a color from the sample

image, place your mouse over the color you want to use and

click. The color of the preview sample image changes

accordingly. To select a color from the Windows Color dialog

box, click on the Coating Color color square.

The Emboss dialog box also allows you to change the light

direction of an image. This makes the outline appear to “raise”

above the surface, or to be “stamped” into it. To increase this

effect, move the Depth slider to the right.

Fish Eye

The Fish Eye effect creates a convex shape in the center of an

image. This results in a distorted 3D effect. You can also control

the light direction, making it appear from the center of the image

or from the boundary.
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Pinch

The Pinch effect works by squeezing the sides and top of an

image in towards the center. The greater the factor of the pinch,

the tighter the squeeze.

Image before and
after applying the

pinch effect

Punch

Punch produces an impact feel to the image by pushing the

image from the center out. The greater the factor of the punch,

the larger the impact. This effect works well with inanimate

objects such as cars and walls.



56 MORPH EDITOR USER GUIDE

Ripple

The Ripple effect creates a ripple over an image, much like that

produced when the wind blows across a pond. You can also

choose to make the ripple start from the center, like the ripple

created by a pebble dropping into a pond.

Image before and
after applying the

ripple effect

Watercolor

The Watercolor effect is only available for RGB True Color

images. Applying this effect gives the impression that the image

has been created using watercolor paint. By adjusting the Stroke

Size in the Watercolor dialog box you can specify the size and

length of each paint stroke. Moving the Moisture Level slider to

the right adds more water to the paint, making the edges of the

“brush strokes” appear darker than the center.
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Whirlpool

The Whirlpool effect “swirls” the image around its center. You

can choose to do this clockwise or counterclockwise, up to a

maximum of 720 degrees.

Image before and
after applying the

whirlpool effect

Wind

The Wind effect creates “wisps” of wind over the image. In the

Wind dialog box you can control the direction of this wind as

well as how hard it is “blowing”.
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3.4.4 Warping an image

Warping is very similar to morphing, and in many ways is the

forerunner to morphing itself. Warping works by using a grid-

based pattern to move control points around an image. Once

moved, the image distorts to the shape specified by the new

position of the points. Warping is ideal when you are working

with individual images and wish to see the effect immediately. It

is also much less demanding on your system resources than

morphing, but you are restricted by how far you can move the

control points within the grid.

An image and the
warping grid
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To warp an image:

1. Click on the image you want to warp to make it active.

2. Choose “Warp” from the Effect menu. The Warp dialog box
opens displaying a sample of the active image.

3. Click on a control point (or at a grid intersection if the control
points are hidden) and drag. (You can only drag within squares
bordering the control point selected.) When you release the
mouse, the grid redraws to accommodate the new position. To
see the effect on the sample image, click on the Testing button.
(If you want to see how the effect looks on the actual image, click
on the Preview button.)

Note: In most cases checking the Good option for Quality Control will
produce adequate results. If you want the best possible results,
check the Better option. This does however require more time to
perform the effect.

4. Click OK. The dialog box closes and the image is warped
accordingly.

Image before and
after applying the

warp effect
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3.4.5 Defining your own custom effect

Many of the effects provided by Morph Editor work by

regenerating a pixel value based on its original value and the

value of the surrounding pixels. The Custom Mapper command

allows you to create your own effects in a similar way using a

unique mapping graph.

When you view the graph, a default mapping curve (line) bisects

the graph on the diagonal (this may change depending on the

previously selected mapping options), indicating that for each

“input” value the “output” value is the same (i.e. Y=X). By

increasing the gradient along the Y axis, you can compress, or

squeeze, parts of an image. The steeper the gradient the greater

the compression. By lowering the gradient along the X axis, you

can expand, or stretch, parts of the image. The lower the

gradient the greater the expansion.
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In the Custom Mapper dialog box you can adjust this curve

directly by dragging your mouse over the graph or by selecting a

predefined option using the tools button. These options make it

easier to control and enhance the mapping curve. Which option

you select depends on the type of effect you want to produce

and the shape of your image. For best results experiment by

using different options and previewing your changes. (To undo

any changes to the mapping curve, click on the Reset button.

This returns the mapping curve to the default Y=X curve/line.)

Notes:

• Each time you select a mapping option, it is applied to the
current mapping curve.

• To save a custom effect, click on the Save button in the Custom
Mapper dialog box. The Save Custom Mapper dialog box opens
allowing you to save the effect to a custom mapper file (CMF). To
bring the same file back into the Custom Mapping dialog box
click on the Load button.
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3·5
Generating an effect video
sequence

One of the more powerful features of Morph Editor is its ability

to allow you to generate video sequences using a single image

and one of the special effects or filters. By specifying the

duration of the sequence, Morph Editor automatically distorts

the image so that it moves from its original state and ends up at

the state defined by the chosen effect.

The procedure to generate an effect video sequence is similar to

generating a morph video sequence, (see p.43). The only

exception is that the Save Effect Video As dialog box, (opened by

clicking on the effect video button or by choosing the Save Effect

Video As command in the Effect menu), has an additional Effect

combo box which allows you to specify the type of effect you

wish to use as well as options to control the starting and ending

level of the effect.
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When in the Save Effect Video As dialog box, you can preview the

effect, or change its current settings, by clicking on the Test

button. (The dialog box for that effect opens.) If you want the

effect to appear at a differing intensity over the sequence, enter

in an appropriate value in the Starting Level and Ending Level

entry boxes. (The values you enter here behave differently

according to the effect chosen.)

Note: If you edit or replace the image used in an effect video sequence
and wish to generate the sequence again, choose the Save Effect
Video command in the Morph menu. This overwrites the existing
video file and uses the original effect settings to save the new
sequence.

Animating a
warping effect

            



64 MORPH EDITOR USER GUIDE

3.5.1 Saving the frames in an effect video sequence

To save the frames of an effect video sequence, choose the Save

Effect Frames As command in the Effect menu. The Save Effect

Frames As dialog box opens. This dialog box is similar to the

Save Video Frames As dialog box, (see p.46), and allows you to

save the frames of an effect video sequence as individual image

files.

When in the Save Effect Frames As dialog box, you can preview

the effect, or change its current settings, by clicking on the Test

button. (The dialog box for that effect opens.) If you want the

effect to appear at a differing intensity over the sequence, enter

in an appropriate value in the Starting Level and Ending Level

entry boxes. (The values you enter here behave differently

according to the effect chosen.)
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· Index

Acquire command, 19

Actual View command, 30

Add Noise command, 53

Add point tool, 42

Adjustment tool, 44

Blur command, 54

Brightness & Contrast command, 52

Browse command, 51

Clear All command, 45

Clear command, 45

Clear Lines command, 45

Clipboard Viewer command, 28

Close command, 22

Compose Image At command, 46

Composite image tool, 46

Connect tool, 42

Connecting control points/lines, 42

Copy Image command, 28

Copy Settings command, 28

Crop command, 26

Custom Mapper command, 64
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Deleting control points, 45

Disconnect tool, 45

Disconnecting control points/lines, 45

Display command, 37

Duplicate command, 19

Effect video tool, 66

Emboss command, 58

Emphasize Edges command, 54

Exit command, 23

File Formats command, 38

Filters

Add Noise, 53

Blur, 54

Emphasize Edges, 54

Mosaic, 55

Motion Blur, 56

Posterize, 57

Sharpen, 57

Fish Eye command, 58

Fit in Window command, 32

Hue and Saturation command, 52

Layout tool, 33

Load image tool, 19

Load Start/End Image command, 19

Lock tool, 30

Media Player, 49

Memory command, 38
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Morph Editor command, 35

Morph Information command, 34

Morph video tool, 47

Mosaic command, 55

Motion Blur command, 56

Move tool, 32

Moving control points, 44

New command, 18

Open command, 16

Paste command, 29

Photo CD command, 36

Pinch command, 59

Placing control points, 42

Play Video command, 47

Playing a video file, 49

Posterize command, 57

Preferences command, 35

Preferences commands

Display, 37

File Formats, 38

Memory, 38

Morph Editor, 35

Photo CD, 36

Previewing a morph, 46

Print command, 22

Printer Setup command, 21

Punch command, 59
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Redo command, 51

Resample command, 25

Restore command, 24

Return tool, 46

Ripple command, 60

Save

active image, 46

effect frames, 68

effect video sequence, 66

morph files, 20

morph frames, 50

morph video sequence, 50

Save Active Image As command, 46

Save As command, 20

Save Effect Frames As command, 68

Save Effect Video As command, 66

Save Effect Video command, 67

Save image tool, 46

Save Morph Frames As command, 50

Save Morph Video As command, 47

Save Morph Video command, 48
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Select Source command, 19

Set line tool, 42

Set point tool, 42

Sharpen command, 57

Special effects

Emboss, 58

Fish Eye, 58

Pinch, 59

Punch, 59

Ripple, 60

Watercolor, 60

Whirlpool, 61

Wind, 61

Swap command, 20

System Information command, 34

Tile Horizontally command, 33

Tile tool, 33

Tile Vertically command, 33
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Tools

Add point, 42

Adjustment, 44

Composite image, 46

Connect, 42

Disconnect, 45

Effect video, 66

Layout, 33

Load image, 19

Lock, 30

Morph video, 47

Move, 32

Return, 46

Save image, 46

Set line, 42

Set point, 42

Tile, 33

Zoom, 31

Undo command, 24

Warping command, 62

Watercolor command, 60

Whirlpool command, 61

Wind command, 61

Zoom commands, 30

Zoom tool, 31


